The Garden Community for Garden Lovers

Essex, United Kingdom Gb

Sick star jasmine & bay tree.

My star jasmine doesn't look very healthy. It is an evergreen variety which I planted last year. It flowered and looked healthy enough but I noticed the other day that the leaves are yellowing, very dull and a bit bent rather than the vibrant green and well formed leaves that they were last year. As it is a evergreen varierty and we have had quite a mild winter I wouldn't have thought it has been frosted but would welcome any thoughts any one has.

I also have a bay tree that looks similar & has done for a while. It is in a pot next to the front door and one of a pair. The other tree is perfectly healthy but this one has yellow, dull and bent leaves too. No signs of any bugs and I trimmed of the dead branches last year in the hope that it may bounce back.

Can you help me revive them both?



Have you applied a vine weevil drench - the grubs could be eating your roots and causing the damage? Hence one pot is okay but the other is not? If you tip out the pot and find small curled up white/cream grubs then you have vine weevil. Do not remove the soil to your compost or other areas until it has been treated, and water the medication around freely!

This may not be your problem, but will eliminate it from the list!!

11 Mar, 2012


Thanks for your help. I'll give that a try.

18 Mar, 2012


I applied a vine weevil drench to both the star jasmine & the bay.

I think the start jasmine probably did have vine weevil due to the notches out of the leaves - I've loaded up a picture. It looks like it isn't going to make it. There doesn't seem to be any new growth and it's lost most of the leaves since the picture. It hasn't quite gone yet so got my fingers crossed but I suspect the vine weevil may have done too much damage before I go to it.

The bay tree (picture loaded up) is a much bigger and more established plant and doesn't seem to have changed at all. Not sure if vine weevil is the problem here. it isn't really dropping any leaves but not got any new growth either. I have tried giving it a feed to promote leafy growth as well but nothing is happening. Any other ideas on what could be wrong with this one?

Thanks for any help you can give.

19 May, 2012

How do I say thanks?

Answer question


Not found an answer?