The Garden Community for Garden Lovers



By marion1


I know I am an impatient little mare and I know its down to the adverse weather we are having but I was lucky enough to have lots of fantastic buds on my Wisterias on 12th April last year. I have just been looking at my photos of the buds and they were huge and this year the branches still look like twigs… I get so excited about my wisterias as I waited years for them to flower and last year for the first time they did, but this year there is no sign of any buds , has anyone else got the same problem?

My long awaited for buds on 12th April last year

And da da… Beautiful flowers last year

More blog posts by marion1

Previous post: Hoping.....

Next post: Chillblanes



I find being patient very difficult too Marion. Hope your gorgeous wisteria begins to form buds very, very soon for you.

30 Mar, 2013


Me too Louisa, everything still looks yuck in the garden!

30 Mar, 2013


Me to keep comparing last year to this year and we are so behind lol :-)

30 Mar, 2013


I dont mean to be unkind Marion but I `m glad that I am not the only one who`s wisteria looks bare, Bonkersbon very kindly gave me clear instructions on how to prune and I was so looking forward to my rewards this year but it looks as if this dreadful weather is holding everything in check ~ so we must have patience.

3 Apr, 2013

Add a comment

Recent posts by marion1

Members who like this blog

  • Gardening with friends since
    19 Feb, 2013

  • Gardening with friends since
    22 Apr, 2008

  • Gardening with friends since
    9 Aug, 2009

  • Gardening with friends since
    27 May, 2012